Team Camaro Tech banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
289 Posts
Discussion Starter #1
I know this topic has been covered numerous times, but in doing a search I have not come up with a specific solution. I'm changing my '69 mono leaf springs to Hotchkis multi leaf springs. I understand that the multis are thicker at the spring perch than the monos. This causes the shock to not line up with original lower mounting plate. In my case the original spring perches are a non issue due to using a universal perch. There are no sides to the perches where the u-bolts go thru. These shocks, perches, and shock plates worked well with the mono springs. My question is do I need to modify the shock plates to relocate the hole for the shocks, or is there an easier, off the shelf type solution?
 

·
Registered
Joined
·
3,064 Posts
Do the shocks line up with the lower shock mount hole on the anchor plates, or are they just not reaching the top of the towers? Do you need shock extenders?
 

·
Premium Member
Joined
·
289 Posts
Discussion Starter #3
The top of the shock is still attached to the car. With the plates bolted back on the bottom of the spring and axle, the shocks are about 2 1/4" short from lining up with the lower hole. Extensions may work.
 

·
Registered
Joined
·
3,064 Posts
The extenders are 2''. If you have a problem getting the shock to fit because of the 1/4'' difference.....You will need to remove your shocks and mount them on the lower anchor plate first, that way you can jack the axle up to fit the top of the shock into the tower.
 

·
Premium Member
Joined
·
289 Posts
Discussion Starter #5
Thanks for the suggestion. Sounds like it'll work. Here's a picture.
 
1 - 6 of 6 Posts
Top