Team Camaro Tech banner
1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
on a 69 camaro 4-speed ignition where you need to have it in reverse to turn the key all the way back to the off position, well just the other day my key ends up not being able to go to the off position. i thought it might have been the linkage from tranny to steering column but it urned out to be fine. i think maybe somthing snapped in the column and is blocking key from going to off position. was wondering if anyone else has run into this problem. the only saving grace is that i have a kill switch and can still turn car off.
 

·
Premium Member
Joined
·
10,083 Posts
Maybe the ignition switch on top of the column broke or the rod connecting it to the key lock slipped out of the ignition switch. I did not get mine tight when I replaced it and it come loose and did not let the switch cut power to the car.
Gary
 

·
Registered
Joined
·
7,608 Posts
Have you tried twisting the column by hand to get it into position? If that works, maybe the lockout linkage between the trans and bell crank, or bell crank and the lever at the bottom of the steering column has slipped.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #4 ·
unreal

already got under car and ajusted linkage and did turn column by hand. did get key to come back one position, but not all the way back. just going to pull column apart next week.
 

·
Registered
Joined
·
8,305 Posts
have you tried totally unhooking that linkage and checking if the column will go back then?
 
1 - 5 of 5 Posts
Top