Team Camaro Tech banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
4,060 Posts
Discussion Starter #1
I got a quadrajet carb on my 69 corvette.
Im not too familiar with quadra sucks but after pulling out of storage I took it for a ride.
everything worked fine
punching it and secondaries opened no problem.
after 15 mins of driving I filled tank with fresh gas.
upon startup engine ran rough and breaking up.
driving it improved the breaking up and primaries worked normally.
upon opening secondaries It backfires and pops out of secondary side
changed filters upon getting home and it still pops and backfires.
(this is original carb with 58000 miles on the car)
thks for the help!
 

·
Super Moderator
Joined
·
32,451 Posts
Might check point gap just to make sure it hasn't changed and the centifugal weights to make sure they extend & retract.
Rebuild the carb on it including replacing the shaft bushings. You'll be glad you did. JMT's.
 

·
Registered
Joined
·
2,777 Posts
Back-firing through the carb? That's likely a timing problem. Check to see if the distributor has walked on you. Then check for a cracked cap or wires that are crossfiring.

Also, cute name for the beloved q-jet ("quadra sucks") but I think if you spent some time learning how a q-jet works and how to tune it, you'd find it to be a beautifully engineered piece of equipment.

FWIW
 

·
Registered
Joined
·
6,276 Posts
If everything else checks out, pull the valve covers and make sure you don't have a cam going away. Flat cams can cause what you're describing too.....
 

·
Premium Member
Joined
·
4,060 Posts
Discussion Starter #9
well pulled the carb and i found the base gasket leaking on the secondary side.
also there is a crapload of black soot etc. at the bottom of the intake plenum.
talked to a local mechanic and he said bad gas and the gasket leak would cause backfire for sure.
carb must be rebuilt anyhow.
Its my wifes vette and she drives it like an ol lady never getting into the secondaries ever.
 
1 - 9 of 9 Posts
Top