Team Camaro Tech banner
1 - 7 of 7 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter · #1 ·
Just got in the rest of the parts for my hideways that were missing from my car when i got it. I'm trying to figure out the mounting of the vacuum canister! I've got an assembly manual with some good pics of the location but noticed one thing. The three legs that come off the canister that bolt to the fenderwell seem to be backwards from the pictures i have. It shows the two legs that are one on top of the other on the side closest to the engine compartment the single leg goes toward the inside of the fender. The canister i have is opposite of this. I have three holes there on the inner fender that may have been the original mounting location but they're no where near the right location for this canister. No matter where i place it against the fenderwell none of three mounting legs will fit absolutely flush without some bending. I can get two flush but the individual leg is at a whole different angle so it would have to be bent a good ways and I don't want to do this if the part is made wrong.
Anyone had this problem with the aftermarket canisters,experienced a defect like this or is the assembly manual wrong? I can see another dimple that may be a hole location to drill but it doesn't seem to make anything line up either.
The new OER vacuum relay valve I got also seems to leak vacuum when you put vac to the center post and hold your finger over the other two. You can hear it seeping out of the bottom of the valve where
a sponge filter should be (right?). Are these valves prone to doing this new? I don't think they should at all to achieve a sealed system with a check valve to seal it off at the engine(ordered a hose kit but it didn't come with the check valve like it was advertised to)
Sorry to ramble on just ill that i sunk a decent amount of money on this stuff and it doesn't seem to be the quality i thought it would be. Any help from you guys the experts would greatly be appreciated!
P.S.
Although I'm not gonna do it I sure feel like doing a little vendor bashing on here right now!!

Dan

[This message has been edited by Bedanobub (edited 01-12-2002).]
 

·
Registered
Joined
·
145 Posts
I dont know if you have a 68 or 69, but the legs on the canisters are different for each year. It sounds like you may have the wrong one. I also had the same problem with my vac. relay switch. I just got a new one today and it doesnt leak at the bottom. From what I have been told, they have had this problem with some of the relays. I hope I have been some help.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #3 ·
I have a 69 and i know the canisters are different. I believe the 68 has two vacuum hookups and the 69 only one. Mine only has one hookup so i believe it is maybe just a defect but i am not sure. I'd like to know for sure what is up for when i call up N . D and raise cain about buying $1149 worth of pa
rts and half of them are BS made in taiwan junk! I can't believe these resto companies. You can just feel the cheapness in most of this aftermarket junk and pay a dear premium for it. It's almost like they got a license to F**K you
 

·
Registered
Joined
·
145 Posts
It sounds like you have a 69 canister with the 68 mounting leg position. I stated that I had to buy a new relay, and now I am going to have to send back one of my repro. actuators because it has a leak! I guess Im not the only one that has these problems. I guess we shouldnt blame the parts houses, they can only send us what the manufactures send them. It does make you mad when you cant wait to get something going and then you have to send half of it back and wait for more parts. Right now I have the passenger side working, but I will have to get the new actuator before I can get the other side going. Good luck with yours!
 

·
Premium Member
Joined
·
4,817 Posts
I'll be following in your steps. I thought the cannisters had been 'redone' and were better quality? Please continue to post your experiences. Thanks.

------------------
Rick Dorion
69 RS Conv,355,M20,4.10's and I don't worry about stone chips.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #6 ·
There wouldn't be any way someone could take a picture of their canister location or maybe have a known good spare to take a pic of? Just to be sure of how the mounting legs are on the tank in relation to the vac outlet and braket for vac relay valve. I'd appreciate it if someone would email it to me- [email protected]. Everything I've seen so far tells me that the canister is defective. Before I pass judgement and start my run around with the resto shop (no names but sarts with an N and ends with a D and is an acronym) I'd like to be positive about what i'm bitchin about!!

Your right in one way about it not being there fault. They didn't make it. They have though, sold it to me so the holder of my money is at fault in my eyes!
I asked them on several parts and the reserve canister was one of the things i asked about for correct fit. They are at fault when they sell flimsy *** cheap quality products and tell you they're a perfect match to the original!
 

·
Registered
Joined
·
145 Posts
I am sending you 2 pictures of the canister in my 69. You wont be able to see much detail, but maybe they will give you an idea of how it is positioned.
 
1 - 7 of 7 Posts
Top