Team Camaro Tech banner
1 - 4 of 4 Posts

·
Registered
Joined
·
725 Posts
Discussion Starter · #1 ·
I found out why my AM/FM blue dot radio doesn't work. I have no speakers! Oddly enough you can hear the radio playing if you turn the volume up all the way. I think it's coming out of the multiplex unit under the dash. I tried to go through the local Chevy dealer but they don't sell speakers anymore. The catalogs want around $30-40 for factory speakers. Is there some decent aftermarket speakers that will sound good with a factory radio?

------------------
'69 RS SS 396 375hp L78 Convertible, M22, 3.31 posi, deluxe interior, gauges, rosewood wheel, AM-FM,fold down seat, tilt wheel, SS wheels, console mounted 8 track player
 

·
Registered
Joined
·
1,515 Posts
If you are wanting some 3 1/2" speakers for under the dash, I'v had some Blaupunkts in my daily driver for about 4 years now and they still sound good.

------------------
68 468 700R4, and here it is;
mutert23
 

·
Moderator
Joined
·
10,164 Posts
DON'T TURN IT UP WITH NO SPEAKERS!
You'll blow out the output transistors!
It's like flooring your engine in neutral.
David

------------------
The older I get, the faster I was!
 

·
Registered
Joined
·
1,000 Posts
Chris, be careful what speakers you choose for your radio. The old Delco radios are designed to be used with 8-10 Ohm speakers, and I have heard of problems that come from using lesser resistance (modern-type) speakers with these units.

[This message has been edited by RPOL72 (edited 04-26-2000).]
 
1 - 4 of 4 Posts
Top