Team Camaro Tech banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
172 Posts
Discussion Starter #1
I installed a new speedo cable not too long ago. I drove my car while my friend drove alongside in another vehicle. I kept in touch with him via a cell phone while driving at various speeds. The test appeared to be positive - speeds matched at all ranges. I thought I was finished with that until I noticed my odometer. According to my odometer, I've driven close to ten thousand miles in the last month. That little odometer is smokin'.
How is this possible. I was under the impression that the speed was in direct relation to the odometer. If the speedometer reading was correct, the odometer would also be correct.
Could there be a problem with my odometer or possibly an incorrect speedo gear in my tranny?
Thanks for any help, Paul
 

·
Registered
Joined
·
8,097 Posts
Sounds like an odometer prob to me, but I've never had mine apart, so I can't tell you for sure what could be wrong. If your speedo gears were off, both the speedo and odometer would be wrong by the same amount.
 

·
Premium Member
Joined
·
172 Posts
Discussion Starter #3
Hi Eric,

The weird thing about all this is that I took the speedo out of the instrument carrier to clean the face, but never touched any of the mechanisms. Once I was finished, I put it right back in. It worked perfectly before hand.
Oh well, the project never ends!! Thanks for the reply, Paul
 

·
Premium Member
Joined
·
2,118 Posts
Realy strange, don't know, could be that it has two digits glued and when one moves, let say the 100's, it takes the left one with him? Think is not a bad idea to remove it again and put some WD-40 or better 3 in one oil on the odometer digit dials. IMHO

------------------
Our affair with Camaros is a live sentence without the possibility of parole. www.geocities.com/c68ss http://home.coqui.net/borench
 

·
Premium Member
Joined
·
172 Posts
Discussion Starter #5
Hi Orench,

I did take notice of the odometer while I was driving. The digits or rollers don't appear to be sticking to each other. They do appear to be turning individually as they should, but you might be right about taking it back out. Thanks for your suggestion, Paul
 

·
Registered
Joined
·
8,097 Posts
Didn't they try putting a Ferrari up on jackstands in "Ferris Beuler's Day Off"? Put the car in reverse and revved her up to get the mileage back . . . but then that didn't turn out so well if I remember.
 
1 - 6 of 6 Posts
Top