Team Camaro Tech banner
1 - 11 of 11 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
I recently bought an reproduction tachometer for my 69 camaro. I have HEI distributor with full 12 volt supply at the coil. I have the tach. wired correctly, wire labeled coil running to the coil, 12 volt supply running to the fuse panel and I have it grounded. The problem is that it seems to read correctly at idle and up to about 1,000 rpm but after that it just falls to 0 rpm. I let out of the throttle and it will pick back up at idle. I have moved the ground twice along with the 12 volt supply at the fuse panel. I have taken the coil off(Accel supercoil) and looked at all of the connections, all is well. Also I had a mini tach installed just before the repro. and it worked like a champ. I have run out of ideas as to what to do next. I am suspecting a bad tach., but thought I would ask for some ideas before heading in that direction. Any help or ideas would be much appreciated.. Thanks Danny
 

·
Retired
Joined
·
26,947 Posts
I think you may have a bad unit but your wording is a bit confusing <BLOCKQUOTE>quote:</font><HR>wire labeled coil running to the coil, 12 volt supply running to the fuse panel and I have it grounded.<HR></BLOCKQUOTE> it makes it sound like you have 3 wires coming from the tach.

My tach only has 2 terminals on the back and I believe one goes to ground and the other to the "tach" terminal on the side of the hei cap (same lead that would go to the coil).


------------------
...Dennis
"The '69, the '96 & the club"
 

·
Registered
Joined
·
352 Posts
You should have four wires:
1) 12V when IGN is on
2) Ground
3) Tach Lead to HEI TACH TERMINAL
4) Interior Light source when Park/Headlights are on to light up tach.

Some Tachs are not to be used on HEI ignition. HAve you confirmed yours is OK on HEI? Most new ones are.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
The tachometer that I have does indeed have 3 terminals. One for 12V, One for the Coil, and one for the ground. What the really weird thing is that I took the tach. out and hooked it up to a V8 chevy truck. The tach wired just the same as in my camaro and it went to work just fine. Makes me wonder if I am having problems with my Accel supercoil or the MSD ignition module.
 

·
Registered
Joined
·
9 Posts
Ratpack is right on. With MSD ignitions you need to hook it up to the tack terminal. You indicated you have it connected to the Accel Supercoil, maybe thats the problem. The tach terminal is a wire comming off the MSD ignition module as I understand it.

Hope this helps. Good luck.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
Well guys, I called MSD and talked with the tech. specialist. He informed me that there are issues with the MSD ignition module related to tachometers. He said that I needed a resistor. The resistor would go between the tach. wire from the tach. and the coil. They are going to send me the resistor at no charge.. Soooooo, If anyone has an HEI unit with the MSD ignition module installed and you are planning on installing an reproduction tachometer, this is something you may want to watch out for. I do thank everyone here for there inputs. This was about to drive me nuts!! HeHe!!!
 

·
Registered
Joined
·
2,372 Posts
I have heard repro tach's have problems working with HEI's but fine with points ignition. A Camaro Parts vendor told me this but i have no experience with it. He also told me the factory tach will work with HEI. Has anyone out there sucessfuly hooked up a repro tach to an HEI? There is a guy that can fix them if needed.
-Mark.
 

·
Retired
Joined
·
26,947 Posts
I have and it works real well... I stand corrected on the 2 wire issue. I verified off my busted up factory orig and there are 3 leads as stated.

It sounds like you found the problem, post back and let us know.

------------------
...Dennis
"The '69, the '96 & the club"
 

·
Registered
Joined
·
1,663 Posts
I am using a repro tach with an MSD 6AL, MSD Blaster coil, and MSD billet distributor. I hooked the tach up to the tach port on the side of the MSD and have never had any problems.

------------------
Pearl blue & white 69 Camaro with supercharged 350, Tremec TKO, and 3.73 12-bolt

See my website updated 4/16/01 at:

www.geocities.com/gheatly
 
1 - 11 of 11 Posts
Top