Team Camaro Tech banner

1 - 4 of 4 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Hi All,
Car is a 1968 Camaro/auto/console car.
Not an RS.
What I've got happening is that,
NOW...
Turn on the right turn signal, left brake light is out.
Turn on the left turn signal, right brake light works ok.
No turn signals, both brake lights operate nice & bright.

NOW FOR THE FUN....
IF at night time, one turns on the lights, no (night time or parking) back lights, except for the brake turn signal light problem mentioned above. That is consistant.

All front lights work correct
Side lights work correct
License plate light works correct.
4 way flasher works correct.
Inside (dash) lights work correct
Back up lights work correct.

I am suspicious it may be the turn signal switch.

How good is my guess?

I will go buy new bulbs and put in, but, kinda doubt it.
I did get lucky like that once, that it only needed new bulbs.
But, both at same time????

I have yet to explore the wonderful world of the wiring schetmatic.
IS it in my 1968 Helms manual?
Can I use my 1967 Camaro Assembly manual for this specific wiring schematic, also?

THANKS!
This problem seems just like my 1974 Corvette tailight problem, too. It "turned" (funny pun) out to be my turn signal switch, too. That's the foundation of this guess.
My Wife & 9 month tool around in this car, so I gotta be extra careful on all ends.



------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 

·
Registered
Joined
·
581 Posts
On your 68 the tail light bulbs are grounded by a smal metal tab that contacts the tail light housing, 99.9% of tail light problems turn out to be this lousey ground set up, Heck I don't know any 68 owner that has not pulled a few hairs trying to trouble shoot a bad ground connection for the tail lights. Check these very careful also take a close look at your bulbs, there should be two filaments visable, and use two contact bulbs.
# 1157
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
HI & THANKS.
I was about ready to go out & start exploring the fun of this cars trunk.
NOW..........
Bulbs is a no brainer, I even have more bulbs to "play with" (good ole' 1157's).
BUT....
this "metal tab".
WHERE IS IT?
I have replaced the taillight housings. I notice no metal tabs. Sounds like I may end up creating a ground strap to something back there.
I also have 4 (two sets) 1968 taillight housings by my left leg. I notice no "tabs" or I am not aware of what the "tab" looks like.
What have I missed?
Even on my 1967 Camaro, I have never noticed nothing like that.
Time to pull out the AIM manaul for my 1967!
I have checked the HELMS book (1968) schematic, also. No mention of a ground for these lights, yet, I know there is one.
THANK YOU SO MUCH!!

------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
Got the brake lights to work
Parking lights to work
Turn signal to work
4 way flashers to work.
BUT.......
I'm gonna start another thread.
Thanks for the "tab" tip, I discovered what ya meant.

------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 
1 - 4 of 4 Posts
Top