Team Camaro Tech banner

1 - 9 of 9 Posts

·
Gold Lifetime Member
Joined
·
2,623 Posts
Discussion Starter #1
My temp guage has never read right (i think) on a 88* day in south fla. it doesn't go over 140*. I have an electric fan (hayden 24339) don't know the cfm rating but it blows like hell. no heater core. the motor is a 383 with edlebrock e-tec vortec aluminum heads. the sender is in the head between # 6 & 8 plugs. should it be somewhere else? i mean temp is temp, right?

 

·
Registered
Joined
·
2,864 Posts
The temperature switch for "idiot" lights is usually in the head, but senders for gauges are typically mounted on the intake manifold close to the thermostat housing.
Eitherway, you should get a reading.. Do you have the correct sender?
 

·
Registered
Joined
·
13,326 Posts
2x the Aussie guy....damn its hard to agree with a bloody aussie lol...
Check the sensor in the kitchen jug and a thermometer...covered in many old posts.
The difference betrween the head and and valley cover locations is negiable
Had done both...run both idiot light and temp gauges.
 

·
Registered
Joined
·
13,326 Posts
Some times one has to bite the bullet real hard m8.
But you guys are slow learners and cant learn from other mistakes...we get rid of a left wing female PM with no family, the you guys fire your PM and put one in.

didnt the all whites do well? .....how did you guys do? ...cough cough
 

·
Registered
Joined
·
13,326 Posts
so we probably agree on that too. (Oh no!)
Nope now you are pushing it m8 lol
Greg has personality...rather than a top driver..hes good, just doesnt quite get all the way
Fan of Ambrose thu...hes getting up thru the ranks in the NASCAR
Didnt like him in the V8s thu
Rod Dickson to...grew up down the road from us...good kid...oh hes grown up now lol

Good to have a couple ANZACs there.
Money must be bloody good...I mean look at all the bloody yanks they have to put up with !!!!!
 
1 - 9 of 9 Posts
Top