Team Camaro Tech banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Need Help!!! My TH350 hasn’t been ran in a long while. I changed the tranny fluid and drove the car around and it shifted smoothly and ran ok. Upon returning home, the fuild was coming out the filler tube at the tranny case. I’m thinking one of two things. The O ring is bad on the tube or the air vent hole is stopped up. I can change the O ring, though not very easy. How is the best way to check to make sure the air vent is open and not stopped up. How is the best way to unstop the air vent, with the tranny in the car, if at all possible, don’t want to drop the tranny, need a trick for this one…Any other ideas are welcome.. thanks
 

·
Registered
Joined
·
2,864 Posts
If your trans hasn't been used in a while, it can be normal for seals to contract and begin to leak.
Before you swap o-rings, just wait and see if it will stop leaking. The o-ring may swell and seal.
If you decide to replace it, drain plenty of fluid first, or you'll be wearing it!

If you want to check that the air vent is clear, try blowing air into the dipstick tube (via a hose perhaps) and see it you or a helper can hear air from the vent. This will definitely require draining the fluid though.
It may be possible to replace the vent depending on what's in your way and how skinny you are! You might be able to remove the tran's x-member and allow the engine/trand to tilt back in order to gain some clearance between the floorpan..
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
What can I use to clean out the air vent ? The tube is not on and I think it goes back about an inch or so and makes a 90 degree turn to the rear of the tranny.. If its stopped up what do people use to unstop it? thanks
 

·
Registered
Joined
·
2,864 Posts
Doesn't sound like the vent to me, although, I'm not 100% sure on the TH350.
My PG has the vent at the highest point, about 2" before the bell housing.

Never known them to block. They're generally made of plastic -just like a rear axle vent, if not the very same part.
Don't use any strong solvent.
Mine has a baffle/cap on it so I couldn't clean it if I tried.
Try removing it perhaps.
 

·
Registered
Joined
·
601 Posts
:noway: dont be spraying nothing in vent. whatever you use will be in trans. change o-ring they get old and rock hard probally leaking for a while slowly now you filled it back up now its leaking more than ever.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Thanks for all the replys.. It was the dipstick O ring, got pulled from the groove and after I got my light on it I could see part of the O ring up near the seat. Anyway, put new O ring on and leaking has stopped. thanks again for the quick posts....:hurray:
 

·
Registered
Joined
·
159 Posts
:confused:

Question for you guys - I'm leaking in the same place. I replaced the o-ring over the weekend, but it did not fix the problem. Still leaking pretty badly. The end of my tube (TH350) goes in about an inch or so when fully seated, and looks like the o-ring groove is way out near the end of the tube. Is this the correct ring mounting location? Or do I roll it up on the tube near the flange?
 

·
Super Moderator
Joined
·
32,765 Posts
:confused:Still leaking pretty badly. The end of my tube (TH350) goes in about an inch or so when fully seated, and looks like the o-ring groove is way out near the end of the tube. Is this the correct ring mounting location? Or do I roll it up on the tube near the flange?
First design of the tube, tube has the same diameter for its length, the O-ring should fit into a groove about an inch up from the end sticking into the case.

There should be an arm welded to the tube to be able to bolt it to a bellhousing bolt to secure the tube and keep it at the correct height/position.

Replace the O-ring and lube it with either petroleum jelly or ATF and squarely insert the tube into the case and secure it with the bolt. I believe there should be a piece of metal welded onto the tube on the outside to set the depth of the tube into the case.
 

·
Registered
Joined
·
1 Posts
someone please help I literally did this simply replaced the o ring on my th350 dipstick and now it won't shift out of 1st please help
 

·
Premium Member
‘67 RS
Joined
·
579 Posts
someone please help I literally did this simply replaced the o ring on my th350 dipstick and now it won't shift out of 1st please help
Check your manifold vacuum line at the trans. Had mine come off and didn't know it and wouldn't shift out of first. Check the connection at the manifold also.
 

·
Premium Member
Joined
·
5,383 Posts
Check your manifold vacuum line at the trans. Had mine come off and didn't know it and wouldn't shift out of first. Check the connection at the manifold also.
Yes this.^ IIRC there is a bracket on the vacuum line that shares the bolt with the dipstick tube. Very possible that you have dislodged the line at the top.

Jeff
 
1 - 11 of 11 Posts
Top