Team Camaro Tech banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3,167 Posts
Discussion Starter #1
I spent most of Saturday cleaning the dash parts that mount on the fireqall and cowl. I cleaned the Astro Vent ducts, new seals. Prepared the heater box, new heater core, seals. Cleaned the defroster duct, new seals. After several minutes of trying to get theh defroster duct back into place, I realized the bottm metal retention bracket was missing and found laying on the floor. Broke it off. After removing the duct and replacing the mount, My buddy (Tommy) and I tried again. Once I got it in, I installed the AstroVent ductwork into the cowl. They went in well, then I questioned if I had put the vent pulls in backwards. Install the kickpanels to test for proper pull cable to vent action, I'm ok, I didn't screw up. Install the new Astro Vent on the passenger side of the dash (new seals) and the Camaro emblem. So far, all is looking sweet and going fairly well. Tommy and I go to install the heater box and as Tommy lifts teh hood, I hear "OH SH&^! It seems as though the screw for the lower defroster duct mount had "pushed" the paint and primer out of the hole instead of cutting through it. My firewall is body color and smoothed. Now I have a "chip" the size of a quarter on the firewall. We called it a day at that point. Sunday, I got a panhead bolt and nut to replace the screw with. I'll repair the damage and move on. I can tell trying to mount the heater box while popping the studs through the firewall insulation and B-quiet will be a chore as well as aligning the heater hose tubes to go through the blower box cover (as it is already installed). Oh what fun. I hope others had a better weekend. :( :rolleyes:
 

·
Registered
Joined
·
125 Posts
Thanks to Isabell, I spent the day cutting up and removing trees from freinds' and neighbors' homes and garages. I'm past Ben Gay, I need morphine (and clean water)...
 
1 - 2 of 2 Posts
Top