Team Camaro Tech banner

1 - 12 of 12 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
i have a 88 iroc with stock tpi 350 and i im not pulling up any codes.the damn car has a miss every so often.sometimes when i come to a stop it will die.you name it ive replaced it:cap , plug wires , spark plugs , fuel filter,checked injectors
rotor, cap , oxygen sensor, vacuum lines , catalytic converter .egr doesnt leak by and has vacuum to it when i rev it a little.i also changed the throttle body out with another from another car.changed out computers and distributer,no change.please give me some insight.or if anyone knows of a good mechanic who knows how to work on tpi fuel injection in the dallas/ft. worth area............thanks billy

[ 10-22-2003, 08:41 PM: Message edited by: 69z28rsbilly ]
 

·
Registered
Joined
·
416 Posts
The MAF. With the engine idling tap on the MAF with a screwdriver handle. If the engine stumbles the MAF is bad.

Disconnect the MAF connector and drive the car. If it runs better the MAF is bad.

Check intake duct work for debris. Know of one guy that ended up with a leaf up against the MAF screen after an air cleaner change.

Bob.
 

·
Registered
Joined
·
572 Posts
You won't get a trouble code for a problem in the secondary side of the ignition ( plugs & wires), unless it is a complete failure, then your code might indicate a rich mixture,
You say you only get a stumble miss as you come to a stop so then my guess your problem is not in the engine but in the tranni, The Torque convertor is staying in lock up,, as you come to a stop, Drop the pan from the trans and replace TCC switch.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
the engine starts cutting out around 220 degrees F every time.its not a constant cut out either.buup........bup..buup ...bp..........bup.buup .ive worked on lots of my own t.p.i. systems but this one has really got me baffled.
please help
and send reinforcments!!!!!!
 

·
Registered
Joined
·
707 Posts
do you have the equipment to interface with the computer?
Milan
 

·
Registered
Joined
·
2,765 Posts
If the TCC is remaining locked when coming to the stop, the engine would just stall...just as if you had a manual tranny and didn't engage the clutch.

My truck doesn't have a computer, but it did the same thing when I accidentally advanced the timing about 4 degrees too far. Some of those motors are advanced so far from the factory, that any more will causes a periodic miss. Not sure how that relates to you car, though.

Do a compression test for a blown head gasket. That's also a probable cause.
 

·
Registered
Joined
·
416 Posts
Originally posted by 69z28rsbilly:
the engine starts cutting out around 220 degrees F every time.its not a constant cut out either.buup........bup..buup ...bp..........bup.buup .ive worked on lots of my own t.p.i. systems but this one has really got me baffled.
please help
and send reinforcments!!!!!!
Ahh, heat related on a 3rd gen. 99% of the time this is an ignition module problem. Can also be the pickup coil (in distributor) or ignition coil. Does it ever want to not start when hot? Then does later once it cools for a while? If so, ignition module first, pickup coil second.

Bob.
 

·
Registered
Joined
·
2,765 Posts
I've usually found when a ignition module gets overheated, it just plain quits...no periodic misfire. Is there something different about the 3rd gen motors?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #10
ive changed the whole distributor out from another car just like it a while back.used other coils also.i dont think the tranny(tcc)is causing the miss at all.i applied a vacuum gauge to the e.g.r. and it has a slow leak,could this be the problem.what other ways could i check for a bad e.g.r.......clueless in texas?????????
 
1 - 12 of 12 Posts
Top