Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
648 Posts
Discussion Starter #1
Im just about ready to finish my engine wiring. Its mostly done but the alt,electric fan relay and repop amp gauge. But as im laying out the wiring I have 3 leads going dircet to my batt. 1 for the alt ,Fan and amp gauge. Not including the factory hot lead through the factory harness. Is there some sort of aftermarket junction block I could use to tap the hot leads to? I just picture a red wire mess in my mind . Any help would be great.
 

·
Registered
Joined
·
8,113 Posts
Yes, definately get a terminal block and put it somewhere close to the battery, probably out of sight. Not only will it look better, but having a big stack of connectors or a bunch on one terminal is bad, it creates resistance, which creates heat, which causes many other problems.
Something like this from ideal
or any number of varitions on it would be good. not sure where you could find such an item in your area, but many of the electrical distributors carry them.
 

·
Registered
Joined
·
648 Posts
Discussion Starter #6
o.k. thanks gang Ill pick up one. One last thing I need to wire my factory repop amp gauge. Im starting from scratch cause the stock amp wires are missing in my harness. From the info I collected is one wire to the charging side of horn relay and the other goes to the alt? Novice elelctrition here any help would be great.
 

·
Registered
Joined
·
453 Posts
spideynut said:
From the info I collected is one wire to the charging side of horn relay and the other goes to the alt? Novice elelctrition here any help would be great.
One wire can go to horn relay (originally it went to main splice), the other to junction block by battery. The battery charge wire must be factory size and length for the gauge to read correctly. If the ampmeter works backwards, reverse the leads. See pic below



You should put 5 amp fuses on the ampmeter leads near the horn relay and junction block. If the battery charge wire ever became open all power will try to go through ampmeter which will fry it in short order without fuses.
 

·
Registered
Joined
·
648 Posts
Discussion Starter #8
I think I got it. I ordered the Jegs terminal today. Where is the original terminal mounting spot? any pics? Thanks Greg.
 

·
Registered
Joined
·
453 Posts
spideynut said:
Where is the original terminal mounting spot? any pics? Thanks Greg.
The original junction block by battery was on the rad support. heres a pic of the original one.
http://www.ss396.com/mm5/merchant.m...llecamino&Product_Code=GQH-118&Category_Code= It is small and doesn't allow for many extra connections. If you don't have one you need one so you can use a fusible link off the battery (highly recomended).
spideynut said:
Im just about ready to finish my engine wiring. Its mostly done but the alt,electric fan relay and repop amp gauge. But as im laying out the wiring I have 3 leads going dircet to my batt. 1 for the alt ,Fan and amp gauge. Not including the factory hot lead through the factory harness.
These items (and anything else extra) should be wired to the horn relay. The reason is the factory ampmeter is really a milivolt gauge and reads the voltage difference between the junction block and the horn relay. The wiring need to be factory (with no add ons) between the junction block and the horn relay for the ampmeter to work correctly.
 
1 - 9 of 9 Posts
Top