Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1 (Edited)
Does this look like the engine is too rich or the plugs are too cold? I'm running a 700 DP with 70 primary jets and 76 secondary jets. The plugs are Autolite Racing AR3933's. Most of my driving has been cruising ( I can't get into the gas much because the trans slips when I do).




 

·
Registered
Joined
·
5,277 Posts
If those plugs came out of a motor that had just been idling for any length of time its hard to tell. Also the photos are a bit too out of focus to get any details.
 

·
Registered
Joined
·
13,338 Posts
Clean the center electrode.. with a magnifing glass look at the tip
It should have a purple discolouration, like when steel gets very hot
only about 1 mm of the tip of the center electode should show the purple heat colour
No colour, plugs to cold, to much plugs to hot
just right, running rich or timing out.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
Sorry about the pictures, that was the best I could do with my camera. The plugs are covered in back soot a portion of the center electrode is white from where the spark hits the ground strap. I had just got back from driving the car around the block. I'll find a magnifying glass and take a look at the electrode in better detail.

Thanks
 

·
Registered
Joined
·
190 Posts
Discussion Starter #7

·
Premium Member
Joined
·
10,082 Posts
I know Kragen does.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #10
autozone does
but anyhow what engine you running
a 650 DP is just about as big as you can go on a 350 smallblock.
also a DP carb on an automatic car is a pita to get right.
355, 10.5:1, Comp XE268, 1.6 roller tip rockers, Brodix IK180's, Air Gap, 1" carb spacer
 
1 - 10 of 10 Posts
Top