Team Camaro Tech banner
1 - 1 of 1 Posts

·
Registered
Joined
·
8,303 Posts
Discussion Starter · #1 ·
Well, I broke the big block in yesterday, and today had it out leaving black marks on the driveway (the little 195 14 roller tires don't even generate enough friction to squeal :) )

I've run into two other issues that I suspect are the reult of having new parts sit too long waiting for me to bring it to life.

Brakes - I tried to reverse/injection bleed the brakes with my Phoenix V12, and I had problems. I used reverse bleeding on my 01 Silverado very sucessfully this year, on a completely dry system, so I decided to try it on the Camaro. I did not bench bleed the master, because in theory injecting the fluid up through I shouldn't have to. On he rear brake side, I could push fluid up to the cylinder, as evidenced by fluid coming out when I just loosened the fitting at the cylinder, but it wouldn't really push into the reservoir. On the front circuit, I could get some into the cylinder but not much (maybe 1/2 full). The master cylinder is a new/reman unit that came with my brake kit. Pumping the pedal didn't seem to free anything up. So, I can think of several possibilities.

1. The seals swelled/seized to the inside of the cylinder because it sat without fluid for 2 years.

2. A little of #1 is happening, but I can't free it with the pedal because I have the wrong push rod.

3. Something in the design of this style master cylinder doesn't allow reverse bleeding.

Any thoughts?

Power steering - I have none... New Cardone 3rd gen box, new hoses, new reman BB PS pump, fluid full and air bled. After reading some of the archived material here, I believe my first check will be the check valve in the pump. What would cause a check valve like that to stick shut on a reman unit? Same thing, just sitting around empty?


Because both of these systems (brake and steering) were just filled yesterday and today, I am hoping that just having them sit in their natural fluids may help in freeing them up. Of course I am hoping for the same thing on the lifter I have that is tapping...
 
1 - 1 of 1 Posts
Top