Team Camaro Tech banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 1970 Camaro with turn signals that don't work. When I turn the switch to the left the left side will light up but not flash. And the same thing happens on the other side except the front light is burned out. None of the lights on the dashboard light up either way. But when I turn on my hazard lights all of the lights on the outside will flash except for the burned out one. And on the inside the light on the right hand side will flash but not the left. Whats the problem?
 

·
Registered
Joined
·
396 Posts
Replace the burned out bulb. Alot of these older cars are set up so if a bulb burns out the indicator will light up but not flash. This is so you know you have a burned out light.
 

·
Registered
Joined
·
67 Posts
you might have a fried flasher too. i think they're mounted right by the fuse pannel, round piece, usu about 1" in dia, sometime tin or plastic.
 

·
Registered
Joined
·
73 Posts
Yup, Rick is right. Make sure all your bulb sockets have good connections also ('70 was a long time ago). By the way, if you put the hazard lights on, then step on the brake, the indicators should stop flashing. That's how you can tell if your brake lights are working


------------------
Matt
http://camarotech1.com
Camaro Tech 1st Generation
 

·
Registered
Joined
·
12 Posts
Sounds like a combination of a burnt out bulb along with a possible bad flasher unit. I have a 69 but have to believe that the signal setup is basically the same. There are two flasher units. One is on the
fuse panel for normal signals and the other was mounted under the center section of the dash. I believe that one is for the emergency flashers but I could be wrong. This would explain why they flash on emergency but not on normal turn signals.

Larry 69 Camaro 454
 
1 - 5 of 5 Posts
Top