Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hey folks,

just got a new to me camaro....'73 Z28 w/350 and M21 four speed. I have owned a couple of 81 camaros but nothing as sweet as this one! My question is this...there should be a vaccuum line from the vaccuum advance on the distributor right? well there is none on the car...might have jumped off in shipping...can anyone tell me where it goes to? the carb is a holley 750 double pumper w/mechanical secondaries...would the vaccuum line go to the car or the manifold and if so where?

any and all help is greatly appreciated!

Donnie

------------------
'73 Z28 w/
'70 LT-1& 4-Speed
WooHoo!
 

·
Moderator
Joined
·
10,144 Posts
You want "ported" vaccum off the carb front.
Find a vaccum port that has vaccum only when the throttle is opened. None at idle.

Your car may have had an advance curve kit installed, in which case many people find the vaccum advance adds too much advance. Most engines run better with a vaccum advance on the street, keeps the plugs clean.
Often you have to change to a vaccum can that adds less advance when you perk up the mechanical advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks David....another stupid question...if the dist. has had an advance curve kit installed....should the vaccuum advance port be left open? i wouldn't think so...right? should it be connected or plugged in this case?

thanks again for the help!
 

·
Registered
Joined
·
252 Posts
Lots of people have different ideas on this. One theory is to advance base timing some extra and disconnect the vacuum advance. Makes for a little increase in performance, especially in a lower compression cammed up engine, but hurts it during normal street driving. I'd set the time at factory setting and use the vacuum advance. Or maybe the advance unit was bad and leaking, causing a rough idle maybe.
 

·
Registered
Joined
·
112 Posts
Homer

if the case happens to be that the vacuum line is simply off, you should do as mentioned and finf a timed port as stated. Make sure the engine is at reccommended idle as the engine being idled too high will have the timed port activated. the port should be on the passenger front side of the carb.

good luck

71 Camairo
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
thanks guys....i just got my car and am in the process of figuring out just exactly what i have on my hands! there have been more than a few mods to the drivetrain of the car and i am still sorting things out.
the engine doesn't want to idle and the first thing that caught my eye was the lack of vaccuum line from the advance to the carb...would this cause the engine to not idle? i will hook up a line and try it out tomorrow...

thanks again everyone...

donnie
 
1 - 6 of 6 Posts
Top