Team Camaro Tech banner

1 - 13 of 13 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter #1
Well while im up here in pa attending school it seems that my car(back home in florida) has started making a noise which is in my dad's opinion and mine (from the vid I seen and from what he has told me) I belive it to be a bad lifter. he told me its coming from the passenger side around the #6cyl when he removed the valve cover he said the #6 intake pushrod had some play in it, he adjusted the valve, it was fine for a few secounds then the tapping started agian. oil pressure is great (55psi cold idle 35psi when warm). tapping does not go away when warmed up.
here's the vid im talking about check it out. http://video.google.com/videoplay?do...06840566745259
 

·
Registered
Joined
·
345 Posts
Discussion Starter #3
anyone???
 

·
Registered
Joined
·
3,934 Posts
I don't know if your motor was OK in the past with a Flat Tappet Hydraulic cam or this is relative to the break in of a new cam; in either case, if a tappet will not stay adjusted, assuming your lash mechanism and rocker arm pivot is solid, your looking at a failed lifter caused by another problem such as a wiped cam lob or bad lifter bore. Just hope it's a failed hydraulic lifter that ill not pump up. I suggest you put in a NEW hydraulic lifter not a used one and give it a try. If the tappet adjustment works loose again, I think you should consider pulling the intake and have a good look.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #6
I have a new solid cam and lifter set from crane I planed on putting in there, now maybe sooner then later. but it wont go in for another 3months
(when I graduate)
 

·
Registered
Joined
·
345 Posts
Discussion Starter #7
no mechanical pump or rod in the block.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #9
yeah I just wanted to make sure I did not sound like anything else to you guys
 

·
Premium Member
Joined
·
11,170 Posts
If its a failed lifter internals, Old school me, I would disassemble that lifter and clean it good before placing a new lifter on that cam.. something may have gotten inside the little pittle valve or become stuck. you might get lucky. If not , sounds like you will be pulling the manifold again in 3 months.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #12
screw in
 
1 - 13 of 13 Posts
Top