Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Ive got a problem with my engine it basically can not idle. Now before this everything was running extremly well. It gets warm and then when it goes to idle it does then stumbles and dies. I dont know what it is. I havent started the engine up in just 2 days. I did see a little oil coming from from intake so it might be a vacuum problem but it did this to when the engine was running fine. So i don't know what to do your help would be greatly appreciated. The carburetor is brand new and the engine to.
 

·
Moderator
Joined
·
10,144 Posts
Like a lot of posts here you are not giving enough information. It makes it difficult to help you.

What engine?
stock or modified?
If different cam what are the specs?
What type/year car?
What type ign? points, HEI or other?
Do you have an external fuel filter on the engine and what type? paper or screen?

Post the infor here and we'll try and help.
David

------------------
Check my web page for suspension info:
David's Homepage
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Can Am Vintage Racer
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Alright i have a 68 camaro with a 383 small block. I have a msd ready to run distributor and a fram fuel filter which is probably paper.I have a 750 db carburetor. I also have a comp cam extreme energy 284. Anymore needed information ill be glad to post. Oh and also i have a 2800 stall. Thanks
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
The engine use to fire right up but now its hard. So the first thing im going to do is check the timing and the springs on my distributor.
 

·
Registered
Joined
·
42 Posts
You said the carb is new? Did you adjust the idle mix screws when you installed it? When I got the carb on my 86 rebuilt, it would slowly lose RPM at idle until it stalled out completely. Turns out they didn't set the idle mix.

It's probably more complicated than that, just a thought.


Squirrels
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
yes i did. It has been running for 8 months very nicely. Until one day i started it and this happened thats why i said it was weird for.
 

·
Registered
Joined
·
59 Posts
did you check for a vacuum leak ? start the car and put your hand over the top of the carb oh ya take the air cleaner off first if the engine starts to idle better what you have done is remove air from the engine and let it breath through the leak after you have determined it a leak take carb spray and spray arounr base of carb and intake manifold if it changes idle or you see air bubbles you found the leak also you might check for a blown power valve if it is a holley good luck
 
1 - 7 of 7 Posts
Top