Team Camaro Tech banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,034 Posts
Discussion Starter #1
Pulled trans apart this morning, this is what I found. Funny thing is that it ran just fine other than a momentary shudder just of idle in first gear. Shifted fine(bark the tires in second and third), no noise. All of the clutches and the band look great.

http://img.photobucket.com/albums/v108/idoxlr8/Transmission/IMG_0347.jpg
http://img.photobucket.com/albums/v108/idoxlr8/Transmission/IMG_0348.jpg
http://img.photobucket.com/albums/v108/idoxlr8/Transmission/IMG_0353.jpg
http://img.photobucket.com/albums/v108/idoxlr8/Transmission/IMG_0355.jpg
http://img.photobucket.com/albums/v108/idoxlr8/Transmission/IMG_0359.jpg
 

·
Registered
Joined
·
1,034 Posts
Discussion Starter #7
I have been driving around like this for about 6-7 months. Car ran fine except the momentary shudder (very light) and if you didn't know the car you would think that it was nothing at all. Don't know when it happened.
Rear end is fine.
Chris, you missed my other post. 2 Hour Rule!

Everett, That's not clutch material, It is metal coming from the ring gear and the inner sun gear bushing, and the sun gear itself as everything was milling it self apart.

I am glad I caught it now instead of after it got catastrophic!
 

·
Registered
Joined
·
348 Posts
Dang, I wish you were closer. I would rebuild that thing in an hour and a half..
 

·
Gold Lifetime Member
Joined
·
2,623 Posts
I have been driving around like this for about 6-7 months. Car ran fine except the momentary shudder (very light) and if you didn't know the car you would think that it was nothing at all. Don't know when it happened.

those t-350's are bad ***!! :thumbsup:
 
1 - 12 of 12 Posts
Top