Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,512 Posts
Discussion Starter #1
i am currently running casterol 30w in a 355 that is putting out 425+ hp. i want to start running synthetic like royal purple but i dont know which would be best for a daily driven performance engine. thanks james

[ 02-08-2005, 06:31 PM: Message edited by: 1968camaro123 ]
 

·
Registered
Joined
·
2,765 Posts
If you don't want to run synthetics, I recommend you use an oil with alot of zinc. Valvoline Racing oil is loaded with zinc...which cannot be found in commonly found oils for modern engines.

The zinc will greatly reduce the wear caused by flat tappet cams with high spring pressures (120lbs+).
 

·
Registered
Joined
·
409 Posts
I just run whatever because to me oil is oil, mostly valvoline 10-30 . I would have to say from what Ive heard mobile1 is the best.
 

·
Moderator
Joined
·
19,844 Posts
straight 40W Valvoline. tore heads off for a swap and only a little discolored but otherwise looks like just came form the shop.
 

·
Retired
Joined
·
16,008 Posts
10-w40 Amsoil 100% synthetic. purrs like a kitten
 

·
Registered
Joined
·
8,108 Posts
i run mobil 1 in everything, my camaro, truck, mustang, wifes volvo, even my lawn mower (seriously). i love the stuff.
i used to run only kendall in my mustang back when i was bracket racing it a lot, great stuff, but i switched to synthetic to see if i could get an extra edge. well, i dont know about the extra edge, but i had an oil pump relief fail and blew my filter apart, and drained my motor. the car was cold, so no smoke, plus i was about half asleep, and i didn't notice the zero pressure until i drove the car over 5 miles on the freeway! i kid not, i almost crapped my pants, but the car was running quiet and fine, so i actually thought the factory gauge died, as it was below zero. well when i pulled over i found the ugly truth. i figured the motor was done, so i filled it back up, put on a filter, and drove half an hour home (with my dad following), and the car ran same as ever.
i pulled the motor and tore it apart anyway, only to find.....nothing!, but a couple scratches in a main bearing. i had the crank polished, threw a set of bearings in, and the car is still running good today, 240K on the clock. i was amazed to say the least, and contributed the feat primarily to the syn it had in it.
just my story (its true), about syn oil
 
1 - 10 of 10 Posts
Top