Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
579 Posts
Discussion Starter #1
my 70 chevelle is blowing white smoke out the right tailpipe.i checked the oil,no milkshakes.the other thing is i filled it with trans fluid last fall,before it was put away for winter.now it,s empty,no puddles and it hasn,t moved.could this be my white smoke? i disconnected the vaccum line from the trans to the carb and it still smoked.could these problems be related?its a 400s.b. with a turbo 400 trans.thanks
 

·
Registered
Joined
·
321 Posts
How long have you run the engine after disconnectng the modulator? That is exactly what I would have diagnosed. It will take it awhile to burn off.

------------------
67 SS
70 Z/28
 

·
Registered
Joined
·
579 Posts
Discussion Starter #3
i only took it off for a few seconds.does that mean the modulater is bad? i didn't see any fluid in the vaccum line. what happens,the carb sucks the fluid through the line?

------------------
68 camaro,hugger orange ,white stripes.327 4 speed.
 

·
Registered
Joined
·
820 Posts
this might not be it,

but we had a old chevy truck that everytime we turned left the engine would blow white smoke for about 1/4 mile. we checked everything. finally a friend told my father that it was his brakes!, how?! well turns out the master cylinder was leaking , it dripped into the booster , when we turned left the fluid rushed to the right and was sucked up the vacuume line , right into the left plenum of the intake. after replacing the master cylinder , problem fixed. I would have Never thought of that in my normal frame of mind.

somthing to check...

------------------
Chris's 67 RS can be seen at http://www.geocities.com/macphreak4evr/index.html
JOIN THE CAMARO NET WEBRING! www.geocities.com/macphreak4evr/webring/webringjoin.htm !!!
 

·
Registered
Joined
·
321 Posts
The same thing happend to a friend of mines 68 Camaro turbo 350. We could not figure out where the tranny fluid was going and it did puff a little a white smoke. The module was the culprit. The vacuum tube inside was not dripping but just had a little moisture.

------------------
67 SS
70 Z/28
 
1 - 6 of 6 Posts
Top