Team Camaro Tech banner

1 - 18 of 18 Posts

·
Registered
Joined
·
304 Posts
Discussion Starter #1
the windshield molding on my 67 is very loose fitting(lost top piece).
I replaced the top molding and the cilps,but it is so loose you can pop it off weith one finger!

the clips don't seem to have an edge to grip the molding .is there different types of clips for different years.I bought the molding and clips from the same camaro supplier(classic muscle).

any help???
thanks!!!!

------------------
camaro's for ever!!! :D
67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros
 

·
Registered
Joined
·
565 Posts
I had the same problem with my 69 Convertible. The molding strip at the top of the wind shield blew off one day while driving. When I replaced it the new strip snapped on to the clips but just did not feel strong enough.
I put a bead of silicone behind it and have not had any problems.
At over $100 I did not want to lose this piece again.
Maybe someone else out there has a better way to keep it down.

------------------
 

·
Registered
Joined
·
1,663 Posts
Several companies are selling clips that don't work. I bought a set and didn't figure it out until after the W/S was installed and I got urethane sealer all over them. Classic Industries sells the corect clips. The incorrect ones I bought were green colored and the CI ones that worked were red.

------------------
Pearl blue & white 69 Camaro with supercharged 350, Tremec TKO, and 3.73 12-bolt

See my website updated 4/16/01 at:

www.geocities.com/gheatly
 

·
Registered
Joined
·
1,988 Posts
Gheatly is correct, I too had this problem (lost my top piece at 70 mph...thought I threw a belt- lost some paint too
).

The clips holding all my trim on the windshield were stainless and had a rounded edge. I could easily pop the trim off with my fingers. My best guess is these are cheap generic clips with an incorrect design for holding Camaro/ Chevy trim.

I bought the red primer ones also, but from Rick's. They fit properly and hold the trim very firmly. They also fit very differently (slide on horizontally) than the incorrect ones (slip on vertically).

------------------
See my '68 RS/ZZ4 at http://www.100megsfree.com/choptop/camaro.html

[This message has been edited by choptop (edited 10-18-2001).]

[This message has been edited by choptop (edited 10-18-2001).]
 

·
Registered
Joined
·
199 Posts
Are you guys serious about the green clips?!! I've had a h*ll of a time trying to get my moulding to stay on. Im gonna look into this a little further.
 

·
Registered
Joined
·
312 Posts
I also experienced this problem and rectified it with the red clips. However I purchased mine from an automotive paint supplier store at fraction of the "leading suppliers" price. Good luck
 

·
Registered
Joined
·
304 Posts
Discussion Starter #7
thanks! for the info guy's !!!

love this site!!!

we need some shirts and/or jackets !

------------------
camaro's for ever!!! :D
67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros
 

·
Registered
Joined
·
257 Posts
i just had this problem last night. the "rear" type molding clips are pretty worthless. the "front" type are either painted or powdercoated red, and they work well. I'd recommend buying two sets of front clips if originality isn't a concern. even if it is, I don't kow who would pull windshield molding to check something like that. I also scratched my paint (grr) when I tried using the back clips.
 

·
Registered
Joined
·
304 Posts
Discussion Starter #9
yeah! chipped mine to on the frt roof line
 

·
Registered
Joined
·
81 Posts
Whitey,Yes there are different clips for front and rear.Second gen camaros use four different clips.Some good auto parts stores sell them all,found one here in michigan that stocks them.They also sell a neat rivet kit that replaces the small pins that hold the clips in place,instead of using screws.

Brian Weil
 

·
Registered
Joined
·
304 Posts
Discussion Starter #13
classic Ind. sent me the green ones,that all they have.
call rick's now!

------------------
camaro's for ever!!! :D
67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros
 

·
Registered
Joined
·
257 Posts
call NPD, they sold me the good ones. ask for the front clips for a 67, they work!
 

·
Registered
Joined
·
199 Posts
I've got the rear trim off now so I'll try giving Rick's a call. I had to tweak green clips to get the trim on in the first place - a real PTA!
 

·
Registered
Joined
·
304 Posts
Discussion Starter #16
just got the infamuos red clips from rick's along with a nice color catalog,I'll try them tonight and let you guy's know.

------------------
camaro's for ever!!! :D
67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros
 

·
Registered
Joined
·
304 Posts
Discussion Starter #17
ATLAST!!!!!!!!!
The clips from rick's worked great (red ones).
nice and tight ,the green clips don't have enough edge sticking out.so they're pretty much useless in my case.

thanks for the good info guy's!!!!!!

------------------
drive it like you stole it!!! :D
67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros
 

·
Registered
Joined
·
304 Posts
Discussion Starter #18
now if that would have been from lil_beast_67 it would hae been scary



OOPS!!! WRONG THREAD!

------------------
drive it like you stole it!!!

67 327 11:1 4spd.
70 454 400thm 10 posi
my camaros

[This message has been edited by 4 speed (edited 10-26-2001).]
 
1 - 18 of 18 Posts
Top