Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Installed new springs on a newly reconstructed front end (from the ground up)with disk brakes replacing the drums. Front end sits about 2 inches or so higher than normal with engine and a few front sheet metal parts on the subframe installed. Put 3 people onto the front end (about 500 pounds) to bring it down. Not a budge. Seems very stiff. Did I get sent the wrong springs? How do I test these springs? What are my options? (Have a 327 factory air 67 RS coupe.)
 

·
Registered
Joined
·
206 Posts
Possible.Could it be that the front and rear were both worn,now with the proper height in front,the rear shows?I just mention it because I've seen this happen before.

------------------
67 RS RAGTOP # matching,
4X4 CHEVY TRUCK
 

·
Moderator
Joined
·
10,144 Posts
Make shure the front lower A frame bushings were tightened with the A frames level, not hanging down.
The bushings have a serrated inner piece in them that bites into the frame. If tightened when the A arms are hanging down, they will be twisted when the car is on the ground. It's hard on the bushings too.
The springs will settle some the first couple of months.
David
 

·
Premium Member
Joined
·
2,049 Posts
Lou, had the same deal with my 67. Learned a few things from my local alignment shop.
The mistake we make is tightening everything down while car is still on jack stands. When you do that the A-arms tend to stay in that position after lowered. The car never has the chance to settle. It's O.K. to tighten the ball joints down. They recomended having full weight of vehicle on suspension, that means motor, radiator with coolant, the works, before tightening down A-arms & tierods. My car settled about 1.5 to 2 inches after they loosened everything & aligned it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
OK guys, looks like I am dealing with some real pros.

I've been looking at this problem for 9 months and no one has suggested the solutions offered by 67drake, davidpozzi and stevo camaro. But, on thinking about your solutions, you all sound like a solvtion to my problem.

"Drake," as the original owner of this machine, I just laid-in the rear springs last week after replacing the bushings. So I really don't want to hear about a "worn rear." Unfortunately for me, the original rear single leaf springs were not replace, only the bushings. But you may be right. On the other hand, I cant see how the rear springs would take any wear over the years, which is the primary reason I did not replace them. (Yes, other than I can't get original GMs, there were other reasons.)

However, it is possible that you are correct in that the front elevation is "the proper height." I never, nor has anyone else, thought about this perspective.

But I realy think davidpossi and stevo camaro are cloese to the truth. Torquing the upper and lower control arms and the upper control arm shaft bushing nut sound the most promising source of the problem. These were done while they were "hanging" in the air withour any engine or weight appiied and the wheels were not on the ground--nor were they even attached.

I plan on loosening the appropriate nuts as stevo camaro suggests, and then wathching the front end slowly and wonderfully sink to a "normal" height as specified in the Assembly Manual. And 67drake, hopefully this height will match the rear end.

Thanks a million guys!!!!!! A job well done. But, I have some more challenges to follow.
 

·
Registered
Joined
·
820 Posts
1 - 6 of 6 Posts
Top